In addition to the development-tools group, Acronis 12.5 requires the packages flex bison openssl-devel elfutils-libelf-devel to be installed, beyond those included with the base Fedora Server 31.

Additionally, it complained about some files missing: classmap.h, be_byteshift.h, and Build.include.

I had to install all of these:

sudo dnf install @development-tools flex bison kernel-headers

ur="$(uname -r)"#5.4.15-200.fc31.x86_64
kv="${ur%%-*}"#5.4.15

wget "https://cdn.kernel.org/pub/linux/kernel/v${kv/.*/.x}/linux-${kv}.tar.xz"

sudo tar -xJvf "linux-${kv}.tar.xz"\
 -C "/usr/src/kernels/${ur}"\
 --strip-components=1\
 "linux-${kv}/security/selinux/include/"\
 "linux-${kv}/tools/include/tools/"\
 "linux-${kv}/tools/build/Build.include"

sudo bash AcronisBackup_12.5*

However, it then started choking so when trying to build SnapAPI:

make: Entering directory '/usr/src/kernels/5.4.15-200.fc31.x86_64'
  DESCEND  objtool
  LINK     /usr/src/kernels/5.4.15-200.fc31.x86_64/tools/objtool/fixdep
/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/9/../../../../lib64/crt1.o: in function `_start':
(.text+0x24): undefined reference to `main'

at this point, I'm probably just going to roll my own bootable backup solution. You don't have to worry about jiggering around with magic modules if the OS you're trying to snapshot isn't actively running

Leave a Reply

Your email address will not be published. Required fields are marked *